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Preface

This guide was written as part of the authors learning process with LyX. The goal of this
guide is to help interested users to apply existing LATEX and BibTeX styles and packages
in the LyX editor. Additionally we discuss some relevant details of con�guration of LyX
in general.

Readers of this guide are encouraged to contact the author with any questions, sugges-
tions or comments, in particular if the information in this document is found insu�cient
or incorrect.

Three cases are used to highlight several challenges encountered when con�guring the
LyX editor. It is hoped that these examples can be generalized also to other styles.

The author would like to thank Prof. Bernt Lie for his help and guidance in both
writing this guide and for testing the suggested procedures in his own work.
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Chapter 1

Introduction

1.1 LATEX and Templates

One of the reasons for the widespread use of LATEX is the possibility to apply templates
and style packages to a document. By decoupling the writing of a manuscript from its
typesetting, the creative process of writing is separated from the task of con�rming to
prescribed publication standards of formatting and layout. Perhaps the biggest challenge
preventing even more widespread use of LATEX is its dependence on speci�c formatting
codes. These are similar to a programming language and are used to describe the non-
textual parts of a manuscript. For users who are accustomed to the comfort of a �What
you see is what you get� (WYSIWYG) style word processor such as Microsoft Word, the
use of LATEX may seem a somewhat daunting challenge.

1.2 LyX and LATEX Templates

A simpler alternative is to use a graphical user interface tool built on top of a LATEX back-
end. There are many such tools to choose from. One option is to use LyX, a self proclaimed
�manuscript processor� rather then a word processor. Unlike Word, LyX is not strictly
WYSIWYG but rather �What you see is what you mean� (WYSIWYM). This slight spin
on the familiar WYSIWYG acronym is indicative of the way LyX works. By o�ering
a standard on-screen layout to be used while writing, the task of manuscript writing is
again separated from the typesetting and layout. However, LyX is not just a front-end
for LATEX. It uses its own �le formats and it is built on top of the LATEX system MiKTeX.
As such, it is not directly compatible with standard LATEX, but the di�erence is not large.
LyX supports all the features of the LATEX language. In fact, a LyX document can be
exported into standard .tex �les.

Since one of the main reasons for using LATEX is the application of di�erent layout �les
it is of interest to verify that such �les can indeed be applied to a LyX document. As is
often the case with free (and in fact open source) software, this process is not straight
forward. In the following, a detailed description is given of how to import a LATEX class
and style package and use it from within LyX as a layout. The demonstration is given for
a Windows PC. Since some of the challenges in this process is locating the correct folders
for placement of �les, some adaption to individual systems must be expected.
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1.3 Directories and File Types

Two particular base directories on your Windows computer will be of particular impor-
tance in the set-up, and will be referred to in the sequel:

1. Base MiKTeX directory1: typically C:\Program Files (x86)\MiKTeX 2.9,

2. Base LyX directory2: typically C:\Program Files (x86)\LyX 2.2.

There are two � sometimes three � �le types that are used by the LATEX system and
one that is used by LyX to de�ne the typesetting of a manuscript, as listed in Table 1.1.

Table 1.1: File types used by LATEX and LyX.
File type Description

.cls De�nes a LATEX document class

.sty De�nes additional styles for a document (aka �package�)

.cfg LATEX con�guration �le
.layout LyX layout �le

As shown in Table 1.1, a type or class of document is de�ned by a .cls �le. Additional
styling can be de�ned in the .sty �le. Typical, a class �le de�nes the structure of a
manuscript, such as an article or a book. It provides de�nitions for typesetting of the
di�erent sections of the manuscript. Packages, or style �les, are used in addition to
a class �le. It amends the class �le with additional functionality, such as graphics or
customization of headers in default LATEX classes. Con�guration �les are sometimes used
for specifying page size and margins settings, as well as font de�nitions.

LyX adds an additional �le type called .layout. This is a combination of a class �le
and style �le in order to form a complete layout description. It is also possible to add more
de�nitions of formatting directly in the layout �les, but this discussion is beyond the scope
of this guide. The de�ned layout can then be used inside LyX to specify the typesetting of
a document. There are many prede�ned .layout �les available in the Resources>layouts

folder, located in the root directory for LyX (usually C:\Program Files (x86)\LyX 2.2

). These can be used as a starting point for creating new .layout �les customized for a
particular publication or institute. Similarly, there are a many class and style �les located
in the MiKTeX folder (usually C:\Program Files (x86)\MiKTeX 2.9).

Observe that LATEX uses a strictly de�ned structure on its folder tree where .cls and
.sty �les are stored. The root directory of any tree must contain a tex folder, which in
turn contains a latex folder. This structure is termed �TDS compliant� by LATEX (TDS
is an acronym for TEX Directory Structure). Users can create their own trees to store
new class and style �les outside of the MiKTeX root folder. As discussed in Chapter 3 of
this document, there can be additional folders located in the TDS tree, such as folders for
storing reference databases and bibliography styles for the BibTeX system. The interested
reader should refer to speci�c LATEX manuals for more details on the TDS tree.

1.4 Case Studies

Three LATEXclasses are used in this guide as examples on how to con�gure LyX. In this
subsection each case is presented and some details unique to each case is discussed. A

1Currently, MiKTeX v. 2.9
2Currently LyX v. 2.2.3
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detailed step-by-step procedure given in Chapter 2. Readers without prior LATEXor LyX
experience are referred to Chapter 2 for details.

1.4.1 SIMS/Modelica Conference Style

As an example of how to set up LyX to use both class and style �les for a conference
paper, this guide demonstrates the con�guration of LyX using the templates for SIMS3

and Modelica conferences. Speci�cally, the template for the SIMS2018 conference is used
as a case study.

The SIMS2018 LATEXtemplates can be downloaded as a zipped �le from http://www

.scansims.org/media-files/conference-templates-master.zip. Click your way into the
LATEX folder. Here you �nd a class �le sims.cls and a style �le titlesec.sty. In addition,
you need the resources folder with the listings-sims.cfg �le.

Later in the document, the location where these �les/directories should be stored, will
be discussed.

The full .layout �le can look something like the following:

#% Do not delete the line below; configure depends on this

# \DeclareLaTeXClass[sims]{SIMS Article(sims)}

# \DeclareCategory{Articles}

# Input general definitions

Input stdclass.inc

Preamble

\hypersetup{

colorlinks ,

linkcolor=black ,

urlcolor=black ,

citecolor=black ,

pdfpagelayout = SinglePage ,

pdfcreator = pdflatex ,

pdfproducer = pdflatex}

EndPreamble

ClassOptions

PageStyle ""

End

The above layout �le will be discussed in detail in Chapter 2. The SIMS style contains
a \bibstyle command, hence no additional bibstyle should be speci�ed in LyX. Therefore
the bibliography style must be left blank, as discussed in Chapter 3. The last section of
the layout �le sets the ClassOptions, speci�caly the PageStyle as empty. This prevents
page numbers to be generated.

1.4.2 Automatica Journal Style

Another example of a LATEXclass �le, taken from the Elsevier Journal Automatica, can
be obtained from http://autsubmit.com/documents/nonhtml/autart.cls. This layout re-
quires only a single .cls �le with no further dependencies.

#% Do not delete the line below; configure depends on this

# \DeclareLaTeXClass[autart ]{ Article Automatica (autart)}

3Scandinavian Simulation Society
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# \DeclareCategory{Articles}

# Input general definitions

Input stdclass.inc

The above .layout �le is simple. It only needs the inclusion of the autart.cls �le. How
to set up such a layout �le, and how to make it work in LyX will be discussed in Chapter 2.

1.4.3 USN Thesis Styles

A third example of relevant LATEXclass and style �les are those used by University of

South-Eastern Norway (USN). These can be obtained from GitHub at https://github.

com/dietmarw/USN-LaTeX. Observe that in online GitHub using Right Click > Save Link

As ... downloads the html code of the page that displays the .cls �le, and not the .cls

�le which is of course what we need. Please ensure that �les are downloaded using
appropriate GitHub procedures.

There are separate document class �les for bachelor, master and PhD theses. Observe
that the three class �les for bachelor, master and PhD theses uses a common base style.
This base style is referred to from within each of the three theses types and must therefore
exist in your local TDS structure. However, it is not necessary to include it in the LyX
layout �le. A .layout �le for the PhD Thesis can be created simply like follows:

#% Do not delete the line below; configure depends on this

# \DeclareLaTeXClass[USN -PhD]{USN PhD Thesis (USN -PhD)}

# \DeclareCategory{USN -Thesis}

# Input general definitions

Input stdclass.inc

The details of how to create the above .layout �le is discussed in Chapter 2. However,
in the case of the USN classes there is a font problem when using them withing LyX. The
default LATEXprocessor in LyX is pd�atex. The USN styles reports a fatal error related to
fonts when pd�atex is used, as shown in Fig. 1.1. Hence it is necessary to specify another
output format. After some initial testing it appears that XeTeX works with the USN
PhD document class.

Ideally we want the change in output format to be con�gured in the .layout �le. This
could potentially be done by adding a line to the layout �le:

OutputFormat XeTeX

Unfortunately, there appears to be a known bug in LyX (v2.2.3), see: https://tex.

stackexchange.com/questions/154719/set-default-output-format-in-layout-in-lyx.

When the OutputFormat speci�cation is used in a .layout �le, it somehow confuses LyX
such that the View button and the corresponding Ctrl+R shortcut is disabled. Hence,
a better alternative is a manual operation for each document to use the USN style. The
root problem is the use of \fontspec in the USN class styles in LATEX, which uses non-
TeX fonts. This is not supported by pd�atex, hence another rendering tool must be used.
XeTeX or LuaTeX seems to be the recommended choices. There are two ways that we
can tell LyX to use non-TeX fonts.

The �rst possibility is to select Document > Settings > Fonts and check the box for
using non-Tex fonts, as shown in Fig. 1.2. This may be the preferred choice as it most
closely matches the actual problem, i.e. that \fontspec in USN styles requires non-TeX
fonts. When non-TeX fonts LyX reverts to another default OutputFormat for PDF's;
PDF (XeTeX). Hence another way to solve the \fontspec problem with the USN styles
is to specify the output format directly. This can be done by selecting the menu options
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Figure 1.1: Fatal error if pd�atex is used.

Document > Settings > Formats. From the drop-down list �Default output format� select
an alternative speci�cation, e.g. PDF(XeTeX), as shown in Fig. 1.3.

Either method works for the USN PhD style, and the result is the same (using XeTeX
as PDF generator). A third possibility is to do the export without using the View button
or Ctrl+R shortcut, by instead selecting the menu File > Export > PDF (XeTeX). It is
however more convenient to ensure that the View button and Ctrl+R shortcut works as
usual.

A �nal step to make the USN PhD style work is to solve the dependency on the USN
logo. These are obtained as a .pd �le from https://github.com/dietmarw/USN-LaTeX/tree

/master/logos. There are both Norwegian and English versions. The logo �les must
be downloaded and stored in the same folder as the .lyx document, not in a sub-folder.
typically a resources sub-folder is used for �gures. This is di�erent from the SIMS style,
where the dependency �les are in expected to be in the resources sub-folder.
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Figure 1.2: Tell LyX to use non-TeX fonts.

Figure 1.3: Selecting di�erent output formats.

9



Chapter 2

Step by Step Procedure

2.1 Inspecting Available LATEX Classes and Styles

Before a new LATEX package can be added to LyX, it must �rst be added to the underlying
LATEX processor. LyX relies on MiKTeX1 to do the processing of a manuscript, hence it
can only use classes and styles that are also known to MiKTeX. To get a list of LATEX (and
also BibTeX) classes and styles supported on the computer system in question, users can
go to the LyX menu Tools > TeX Information. As shown in Fig. 2.1 the TEX Information
dialog provides a detailed list of all installed class and style �les, as well as their full path
� if Show path is checked.

Figure 2.1: Screenshot of the TEX Information dialog for a particular system. In the top
left corner there is a selection for what type of �les to list. In the right hand corner a
selection allows to show the full path of each �le.

Presumably, the style of interest is not listed in the TeX Information dialog.

2.2 Creating a TDS compliant directory tree for LATEX �les

Before adding new classes and styles (e.g., for SIMS), a custom TEX Directory Structure
(TDS) compliant root is needed. MiKTeX already contains such a folder structure for

1...or TeXLive
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pre-installed class and style �les. It is possible to add the �les in that folder structure with
administrative rights, but it is better to put your special class and style �les elsewhere!

The root of the TDS compliant tree is known as the TEX and METAFONT directory,
the TeXMF directory. To install new classes and styles, it is thus recommended to create a
local TeXMF directory, e.g., named LocalTeXMF � in the examples to follow, the LocalTeXMF
directory is created as follows: D:\Dropbox\_LIBRARIES\LocalTeXMF.

Next, before any class and style �les are installed, the TDS structure must be installed
under the LocalTeXMF directory: �rst, the LocalTeXMF directory must hold a sub-folder
named tex, and this directory tex must in turn hold a sub-folder named latex. See
Fig. 2.2.

Figure 2.2: Example of a TDS Compliant folder structure.

At this stage, the TDS structure has been created. However, we are not done until
we have made MiKTeX aware of the TDS structure and where to �nd our class and style
�les. Before any �les are added to the latex directory, we should make MiKTeX aware
of our LocalTeXMF directory. In other words: we need to add the LocalTeXMF directory
to MiKTeX's list of directories in which to search for class and style �les. This is done
through the MiKTeX Settings tool.

The easiest way to start the MiKTeX Settings tool is to click in the Windows search
icon on the task bar and start typing MiKTeX... � something similar to Fig. 2.3 shows
up � possibly with the wording (Admin) appended.

Figure 2.3: MiKTeX Settings can be found by Windows search.

Launch the MiKTeX Settings tool by clicking on the the icon.
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Figure 2.4: Contents of the Directories tab in MiKTeX Settings.

In the MiKTeX Console tool, click on the Directories tab and then click on the +

symbol, then navigate the File Explorer and select the LocalTeXMF directory that you
just created2, and click OK. If the chosen folder does not contain the appropriate TDS
compliant folder structure, there will be a warning message. However, if you have followed
the instructions, it should look like in Fig. 2.4.

2.3 Adding Class and Style Files, etc.

Now that MiKTeX has been informed of a new location to search for class and style �les,
the relevant style �les must be added. These can be added directly in the new latex

subdirectory under the LocalTeXMF directory. However, it is recommended to �rst create
a lyx subdirectory under the latex directory, and place the class and style �les which are
dependencies of a LyX layout in the lyx subdirectory.

For the case of the SIMS style, the class �le sims.cls and the additional style �le
titlesec.sty should thus be placed in the lyx directory, as shown in Fig. 2.5.

Figure 2.5: Adding new style �les to the chosen TDS tree.

Observe that for the SIMS template, directory resources holding the listings-sims.

cfg �le does not belong in the TDS tree! See below!
Once the class and style �les have been added to the lyx folder, we need to use the

MiKTeX Settings tool to re-scan all its folders for the new class and style �les. This
is done as follows: click in the Windows search icon on the task bar and start typing
MiKTeX... � something similar to Fig. 2.3 shows up � launch the MiKTeX Settings

2NOT the tex or latex directories, but the LocalTeXMF directory!
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tool by clicking on the the icon. Next, choose the pull-down menu Tasks, and select
Refresh file name database. A popup dialog as in Fig. 2.6 is shown while the system is
working.

Figure 2.6: Scanning for package de�nitions.

The �nal step of adding the new packages to LATEX is to verify that LyX can now see
them. This can be done by using the TEX Information dialog under the Tools menu in
LyX, as shown in Fig. 2.7. Note that it may be necessary to click the Rescan button. A
popup dialog as in Fig. 2.6 is shown while the system is working.

Figure 2.7: Verifying that the new class and/or style is now available in LATEX.

You should now be able to see the sims.cls �le under the LocalTeXMF/tex/latex/lyx

directory by scrolling to the bottom of the LATEX classes.

2.4 Creating a new LyX layout

Now that MiKTeX has been made aware of the new class and style �les, it is time to
con�gure a layout �le for LyX. Start at the base LyX directory (e.g., C:\Program Files

(x86)\LyX 2.2) locate the Resources, and then the layouts folder where LyX stores all
its layout �les. Unlike MiKTeX, LyX wants all layout �les stored in the same folder.
Figure 2.8 shows an example of the Resources > layouts folder located under the base
LyX directory.
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Figure 2.8: LyX Resource layout folder.

Note that this folder is protected by Windows � adding �les to this folder will require
administrator privileges. It may not be possible to save a �le directly to the protected
folder. Instead save the layout �le to, e.g., Desktop and copy it to the Resource > layouts

folder manually.

Thus, �rst a sims.layout �le must be developed, and then this �le must be copied into
the layouts folder as described above. In general, creating a layout �le is complicated.
A good example of a layout �le is the aa.layout included in LyX v.2.2. However, for the
SIMS template, we only need the simplest layout �le. Thus, use an ASCII editor and
insert the following code into the �le, and save the �le as sims.layout in the LyX layouts
folder. Some general suggestions for extensions that can be added to the layout �le are
given in Section 2.6.

1 #% Do not delete the line below; configure depends on this

2 # \DeclareLaTeXClass[sims ,titlesec.sty]{SIMS Article(sims)}

3 # \DeclareCategory{Articles}

4 # Input general definitions

5 Input stdclass.inc

The �rst line above is only a comment. The second line contains the de�nition of
the class. The keyword \DeclareLaTeXClass de�nes the link between a LyX layout and
LATEX class and style �les. In the square brackets [], add �rst the name of the cls �le,
without the .cls su�x. Then list any additional style �les with the .sty su�x. This is
the convention used in the pre-installed layout �les. In the curly braces {}, de�ne the
name of the layout as will be shown in LyX. By convention, an arbitrary chosen name
is used with the actual LATEX .cls �le name in parenthesis. The third line de�nes the
category of the new layout. This determines where in LyX list of layouts it will be located.
Here, Articles is chosen since the new layout is created for SIMS2018 conference. The
last two lines of the layout �le is �rst a comment declaring that what follows is general
de�nitions of input �les, followed by a inclusion of a standard class �le. These two lines
appear to be included in all the prede�ned layouts and should be kept as-is.

Once the layout �le has been created, saved and copied into the Resources > layouts

director, the next step is to refresh LyX's list of layouts. This is done from the Tools
menu in LyX. Select the option Reconfigure, which will launch a re-scan of all the layout
�les.
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Figure 2.9: LyX recon�guration complete.

The recon�guration is complete when LyX pops a message as in Fig. 2.9. Before the
new layout appears as an option in LyX Document Settings, LyX must be restarted.

Figure 2.10: Selecting the new layout for a document.

Now the newly created layout is available as a selection from the Document > Settings

> Document Class menu in LyX. If the underlying LATEX �les are not found, the layout
may still appear in the list, but in gray with the pre-�x �unavailable�. This indicates a
problem with the LATEX system, such as invalid TDS folder structure or missing class or
style package �les.

2.5 On dependencies on resources

Some LATEX style packages, such as the sims example used here has dependencies on
certain resources. The sims.cls �le requires a con�guration �le listings-sims.cfg which
must be located in a folder named resources. This resources folder must be located
in the same directory as the .lyx document, and the resources folder must contain the
listings-sims.cfg �led downloaded as part of the SIMS template.

The resources folder may also contain other document relevant �les, e.g., �gures, etc.
� or �gures may be imported from other directories.
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2.6 Extending the layout �le

There are a large variety of settings that can be con�gured through the layout �les of LyX.
One useful possibility is to add a LATEX preamble that will be used for all documents of
a particular layout. For example, to get rid of the red, green and blue frames around
hyperlinks, use the LATEXcommand \hypersetup by adding the following to the layout �le
after Input stdclass.inc:

Preamble

\hypersetup{

colorlinks ,

linkcolor=black ,

urlcolor=black ,

citecolor=black ,

pdfpagelayout = SinglePage ,

pdfcreator = pdflatex ,

pdfproducer = pdflatex}

EndPreamble

This preamble is taken from the example article contained in the SIMS style package.
By adding this to e.g. the SIMS Layout �le for LyX we don't need to add it to the
preamble of the document itself. Presumably, any LATEX command can be added to the
default preamble for our LyX layout using the above con�guration. It is supposedly
possible to achieve the same result using Document > Settings > PDF Properties > Use

hyperref support from the LyX menu system, but this option appears to not work
correctly. Hence it is better to use raw LATEXcode in the preamble de�ned in the .layout
�le to achieve the same result.

Observe that after making changes to a .layout �le, LyX needs to be updated by
accessing the menu option Tools > Reconfigure, the same way that was done previously
when creating a new .layout �le.

2.6.1 Calligraphic fonts

There appears to be an issue with the SIMS style which makes calligraphic fonts italic.
A possible remedy for this is to add

\DeclareMathAlphabet {\ mathcal }{OMS}{cmsy}{m}{n}

to the preamble, as discussed here: https://tex.stackexchange.com/questions/67881/

resetting-mathcal-font-to-default (viewed 22.05.2018).

2.7 Other settings

2.7.1 Program listing style

There are several other settings in LyX that may be of use. One such example is the
possibility to customize program listings. As default, inserted program listings are printed
using the same fonts as regular text, which makes it di�cult to distinguish program
listings from regular text, especially when used inline. It is possible to set the font for
each program listing manually, but this process can be labor intensive. A better option is
to select the document settings menu Document > Settings > Listing and supply default
formatting options here, as shown in Fig. 2.11.

Observe that there are exists a rather large selection of settings for the Program
Listings package, including possibility to format code according to a speci�c language.

16



Figure 2.11: How to set font and size of program listings.
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Chapter 3

BibTeX Styles

3.1 What is BibTeX?

The most popular bibliography system used with LATEX is BibTeX. This system is natively
supported in LyX. A BibTeX system consist of a database .bib �le where a set of references
are stored. A tool such as JabRef can be used to setup and maintain the database.
One your references are added to the BibTeX database, they can be added to your LyX
document.

3.2 Add a BibTeX bibliography

The �rst step is to add a bibliography by selecting the menu Insert > List/TOC > BibTeX

Bibliography as shown in 3.1.

Figure 3.1: Insert a BibTeX bibliography by selecting the LyX menu Insert>.

This menu selection shows the BibTeX Bibliography con�guration tool shown in Fig.
3.2. Here we will add one or more .bib database �les to our bibliography. Note that only
citations that are found in the BibTeX databases added here can be used in the document
later.
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Figure 3.2: Setup BibTeX databases for the bibliography.

To add a new BibTeX database, click the Add button. This opens a list of all known
BibTeX databases on your system. If the �le you want to add is not present in the
list, it can be added manually by using the Browse button and navigating to the correct
�le. If you store your .bib �les within a TDS tree that is recognized by MiKTeX, the
database will be shown in the list. A good choice is therefore to store your .bib �les in the
LocalTexMF folder LocalTeXMF/bibtex/bib. Observe that just as .cls �les must be stored
in LocalTeXMF/tex/latex there are requirements for sub-folders for .bib �les.

Once all the necessary BibTeX databases has been added, a bibliography style can be
chosen. The default choice is plain which gives a bibliography where the references are
numbered. For a author/year style, use instead plainnat, or choose another bibliography
style according to the speci�cations of your journal. Some document classes, such as
our SIMS example, already have a bibliography style included. In such cases, the style
selection in the dialog of Fig. 3.2 must be kept empty in order to avoid a compilation error
due to multiple \bibstyle commands. Observe also that the Add bibliography to TOC

is not checked. This option is known to create problems with certain LATEX styles such
as SIMS. If checked, this option introduces a dependency on bibtotoc.bst which LyX
cannot �nd. Further, it adds another \bibstyle command and therefore causes the same
problem as specifying a non-empty Style �eld.

After completing the bibliography con�guration, click on the ok button. There should
now be a BibTeX Generated Bibliography tag inserted into your LyX document.

3.3 Inserting citations

Once the bibliography is con�gured, adding a citation is done from the LyX menu Insert

> Citation , or alternatively using the corresponding menu bar button. Either option
opens the citation dialog shown in Fig. 3.3.
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Figure 3.3: Insert a citation.

The left side of this dialog list all the references in the con�gured BibTeX databases.
Select the references you want to insert and click the Add button and click ok when done.
The reference should now appear in LyX.

Observe that it is possible to further con�gure citations in the text by selecting the
LyX menu Document > Settings > Bibliography as shown in Fig. 3.4.

Figure 3.4: Let the citation style remain as default to avoid duplicate invocations of the
natbib package, if that package is already used in the class or style �les.

Here, options for the natbib package can be con�gured. This allows more options for
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each citation, such as e.g. choosing whether or not the author name should be located
within brackets. Observe however that if the natbib package is already con�gured in the
.cls �le, using the LyX con�guration tool can cause a con�ict which in turn produces a
compilation error. The latter is the case for the SIMS style example used here.

3.3.1 On BibTeX formatting

When setting up the BibTeX database it is important to keep in mind that the de�ned
text here will eventually be imported to a LATEX document. Hence, certain characters
should be avoided. For example, the use of a dash (-) is problematic since this character
exists outside the 0-127 range of the ASCII table (there is a di�erence between dash
and minus). Instead use the �math mode� syntax $-$ which forces a dash type glyph
that is ASCII compatible. There are also other symbols that can be problematic for
LATEX such as ö and ô. Instead, use the special symbol and escapes characters de�ned
here: http://www.bibtex.org/SpecialSymbols/.
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Chapter 4

Tips and tricks

4.1 Review

LyX supports reviewing manuscripts by marking changes in a way similar to that used in
Microsoft Word. First, the review toolbar must be enabled, as shown in Fig. 4.1.

Figure 4.1: Enable review toolbar.

When the toolbar is enabled, a panel of buttons is available for controlling the marking
of changes, as shown in Fig.

Figure 4.2: Buttons for controlling the review process.

The �rst button toggles the automatic marking of changes. When turned on, LyX
will automatically mark any changes to the manuscript. Additions are presented as blue
underlined text while deletions are marked with light blue text with and a strikethrough.
An example is shown in Fig. 4.3.

Figure 4.3: Example of review changes with deleted and added text

The second button toggles whether or not the marked changes are exported when
creating PDFs.
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The next three buttons are used for navigating to the next marked change in the
text, accepting the change or rejecting the change, respectively. Note that both accepting
and rejecting changes are applied to any marked text, thus it is possible to accept/reject
multiple changes at once. Once a change has been accepted/rejected, this decision can be
undone using the standard Undo command (or Ctrl + z).

Button six is used to launch a merge changes wizard. This tool searches through the
manuscript for any changes and prompts the user for an accept/reject decision. Button
seven and eight can similarly be used to change or reject all changes in the manuscript.

The last two buttons can be used to add editorial notes in the text, and to navigate to
the next such note. Notes are yellow highlighted text that is not exported to the PDF and
can be used for writing comments in the manuscript for future reference. Under the menu
Insert > Note There are some other possible comment/notes options that can also be used
for similar purposes. The yellow highlighted note is a LyX feature, while the comment
option is a LATEXstandard feature. Neither should be confused with the % symbol used in
LATEXto comment out raw code. An example of both types of notes/comments are shown
in Fig. 4.4.

Figure 4.4: LyX and LATEXstyle notes and comments.
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Chapter 5

Conclusion

When writing for publications, in particular for scienti�c journals and conferences, con-
�rming to a speci�c layout is a strict requirement. While there are advantages in sim-
plicity of Microsoft Word, the end result can hardly compare with that of a proper
LATEX manuscript. For users not inclined to invest the necessary time to learn raw LATEX,
the use of a front-end system such as LyX can be a good choice. The drawback is that
these systems, unlike Microsoft Word, requires some e�ort to con�gure correctly. As
this guide has shown, there are some steps that must be executed in order to add new
LATEX layouts for use in LyX. However, the end result is generally worth the extra e�ort.
Once a user learns to navigate the con�guration and setup of LyX, the creative writing
process is just as easy as in Microsoft Word.
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